HELPWORDチュートリアル HELPWORDチュートリアル

HELPWORD圧縮ファイルの中には雛形として使用して頂くようにHELPWORD文書が含まれています。このチュートリアルではこの雛形の使い方の説明をします。

チュートリアルに入る前にあらかじめTEMPLATE1.DOC、TEMPLATE2.DOCをバックアップとっておいてください。


レッスン１ - TEMPLATE1.DOC

TEMPLATE1.DOCは一番簡単なWINヘルプを作成する為の雛形ファイルです。以下のような目次のヘルプになります。

【目標】

1. HELPWORDの基本設定ができるようになる。

2. トピックを追加／変更できるようになる。

3. リンクを追加／変更できるようになる。

4. WINヘルプを作成できるようになる。


基本設定

この雛型の基本設定は次のようになっています。

項目 | 値 | 設定画面
HELP WORKSHOPのプロジェクト名 | TEMPLATE1.HPJ | 「HELPWORDプロジェクト－設定」
WINヘルプのファイル名 | TEMPLATE1.HLP | 「HELPWORDプロジェクト－設定」
WINヘルプの目次ファイル名 | TEMPLATE1.CNT | 「HELPWORDプロジェクト－設定」

これらの基本設定の変更を行い、ヘルプファイル名を変更して別名で保存します。

①. TEMPLATE1.DOCを開きます。
HELPWORDツールバーが表示されています。

表示されていない場合、メインメニューの「表示－ツールバー－HELPWORD」をクリックしてチェックを入れて下さい。

②. 「HELPWORDプロジェクト－設定」を選び、プロジェクトの設定を開きます。
ヘルプ・ワークショップ・プロジェクト名、Winヘルプのファイル名、目次ファイル名を“ABC.HPJ”、“ABC.HLP”、“ABC.CNT”に変更して設定ボタンを押します。
閲覧は階層単位、ヘルプ全体はレッスン２で説明します。

③ メインメニューの「ファイル－プロパティ」を選び、プロパティダイアログを開きます。

④ ファイルの概要タブをクリックします。

⑤ タイトルを”ABC”と変更して下さい。
タイトルプロパティはWINヘルプのタイトルになります。

③. HELPWORDツールバーの「ファイル－名前を付けて保存」で名前につけかえます。
ファイル名を”ABC.DOC”にして保存ボタンを押して下さい。

以上の操作で基本設定を変更して、雛形を別名で保存ができました。


トピックのタイトル変更

トピック１のタイトルを変更します。

①. 文中の”トピック１”の上にマウスの矢印を移動し、ダブルクリックでトピックダイアログを開きます。

②. トピックダイアログでタイトルを変更して設定ボタンをクリックします。


トピックのコピー

トピックをコピー／貼付けで追加します。

①. “トピック２”のタイトルをコピー（Ctrl+C）します。
注意「□□トピック２↓」の段落全体をコピーします。
（WordのバージョンによればLLトピック２↓」と見えることがあります）

②. 適当な場所の行頭に貼付けます（Ctrl+V）。

HELPWORDでは複数のトピックが同一コンテキストIDを持つことは許されません。トピックダイアログを開いて、設定を変更します。

③. 貼付けた”トピック２”の上にマウスの矢印を移動し、ダブルクリックでトピックダイアログを開きます。

④. 好きなタイトルに変更して下さい。

⑤. 未使用コンテキストID取得ボタンを押して新しいコンテキストIDを取得します。

⑥. 設定ボタンを押すればトピックのコピーは完了します。


トピックの追加－ゼロから作る方法

今度は全くのゼロからトピックを作ります｡

①. “トピック５”のタイトルを選択して下さい。

②. HELPWORDツールバーの「HELPWORD編集－トピック」を選びトピックダイアログを開きます。

③. 未使用コンテキストID取得ボタンを押します。

④. 設定ボタンを押します。

以下のようにトピックが作成されます。


リンクの追加／変更

リンクを作成します。

①. 下の文書の”好きなタイトルへリンク”と文書を入力して選択します。

②. HELPWORDツールバーの「HELPWORD編集－リンク」を選びホットスポットダイアログが開きます。

③. リンクさせたいトピックをトピック一覧の中から選んでダブルクリックします。

④. 作成ボタンをクリックして下さい｡

以下のようにリンクが作成されます。

なおリンクファイルは別HELPWORD文書へリンクさせる時に使用します（この機能のテスト量を考えるとあまり信頼していません）。


WINヘルプの作成

それではこれまで編集した文書からヘルプを作成します。

①. 「HELPWORDプロジェクト-Winヘルプ作成」を選び、ヘルプの作成ダイアログを開きます。

②. ヘルプワークショップ実行ボタンを押しヘルプ・ワークショップが開きます。

③. ヘルプワークショップ実行ボタンをクリックし、Save and Comple ボタン押します。

④. ヘルプの作成ダイアログのヘルプファイル表示ボタンを押して作成したWinヘルプを確認してください｡

レッスン１はこれで終わりです。これまでの説明で簡単な構造のWINヘルプを作成できるようになったと思います。レッスン２ではHELPWORDの便利な機能、トピックの自動生成等について説明します。


レッスン２ - 引き続き同じ雛形を使って

引き続き同じ雛形を使ってレッスンを続けます。

【目標】

1. トピックの自動生成が行えるようになること。

2. リンクの自動生成が行えるようになること。

3. キーの追加が行えるようになること。


トピックの自動生成

トピックの自動生成します。

①. 下の赤点線の部分の文を文書の最後に追加します。

②. “トピック７”、“トピック８”（下の赤丸の段落）のどこかをクリックして、HELPWORDツールバーのトピックボタンを押します。

下のようになります。

④ 「HELPWORD編集-トピック自動生成」を選びトピックダイアログを開きます。

⑤ 下のようにトピックの候補のタイトルが一覧されています。
初期状態は全選択状態になっています。トピックにしない候補の選択を外します。
（トピックダイアログからトピック候補付近の文を見る場合は、上下カーソルキーで候補一覧の目的のトピック候補へ移動してトピック表示ボタンを押して下さい）

⑥ 設定ボタンを押します。

トピックの自動作成ではまとめてトピックを作ることができます。

これで自動生成の方法が分かったと思います。

しかし実はトピック自動生成には事前準備が必要です。雛形文書は既にこの準備が行われているので必要ありませんでしたが、HELPWORDを使いこなすにはこの事前準備を理解しなくてはなりません。


トピックの自動生成 事前準備

HELPWORDでは段落スタイルによってトピックの候補にするかどうかを判断しています。


トピックスタイルについて

HELPWORDではトピック自動生成でトピック候補に選ばれる段落のスタイルのことをトピックスタイルと呼びます。

トピックスタイルは次の４種類があります。

l 「普通のトピック」用

l 「ポップアップするトピック」用

l 「セカンダリ・ウィンドウに表示するトピック」用

l 「トピック内のリンク先」用

HELPWORDではリンクする場所で、リンク方式（リンク先のウィンドウに開き方,、別のウィンドウ、ポップアップで開いたり、現在のウィンドウで開いたり等）を決めるのではなく、トピック自身の属性として指定されます。

例えばポップアップとして指定されているトピックはどこからリンクされてもポップアップします。


トピックスタイルの設定確認／変更

トピックスタイルの設定内容を確認して変更してみます。

① HELPWORDツールバーの「HELPWORDプロジェクト－設定」を選びプロジェクトの設定ダイアログを開きます。

② トピックスタイルタブを開きます。

「2ndウィンドウ」はセカンダリ・ウィンドウの選択用です。

③ ポップアップをクリックします。
ポップアップ・トピックスタイルで登録されている段落スタイルが表示されます。

④ ノーマルをクリックします。

⑤ 未選択スタイル一覧の「トピック」を選択し「＞」ボタンを押します。
逆に選択済みスタイル一覧から段落スタイルを選んで「＜」ボタンを押すと解除されます。

⑥ 設定ボタンを押してトピックスタイルの編集を確定します。

セカンダリウィンドウのトピックスタイルには2ndウィンドウ名の指定が必要です。初期状態では”main”というウィンドウを選択することができます。

また規定値として保存ボタンを押すと新規HELPWORD文書を作成する時にこのトピックスタイルになります。


トピックスタイル・ボタンについて

レッスンでトピックボタンを押しました。

このボタンは段落スタイルをノーマル・トピックスタイルにする機能があります。

横に並んだセカンダリウィンドウ、ポップアップ、ブックマークボタンもセカンダリウィンドウ・トピックスタイル、ポップアップ・トピックスタイル、ブックマーク・トピックスタイルに対応したボタンです。


トピックスタイル・ボタンの設定変更

トピックスタイル・ボタンの設定を変更してみます。

① HELPWORDツールバーの「HELPWORDプロジェクト－設定」を選び、プロジェクトの設定ダイアログを開きます。

② トピックスタイルボタン・タブを開きます。

トピックボタンの段落スタイルを ScrollTopic 段落スタイルに変更します。

③ 下の赤丸の矢印をクリックします。
ドロップダウンにノーマルのトピックスタイルに含まれる段落スタイルが一覧されます。

④ “ScrollTopic”とクリックします。

⑤ 設定ボタンを押します。

下のように変更されます。


HELPWORD専用段落スタイルについて

NoScrollTopic、ScrollTopic、PopupTopic、SecondaryWindowTopic、BookmarkPoint、トピックはHELPWORDで定義されている段落スタイルです。この段落スタイルはそれぞれ最初からトピックスタイル専用の段落スタイルとして定義されたものです。「トピック」以外はそれぞれ見かけ上区別できるようになっています。


NoScrollTopicとScrollTopicの違い

NoScrollTopic で作成したトピックのタイトルがスクロールアップしません。

ScrollTopic で作成したトピックのタイトルはスクロールアップします。

【NoScrollTopicで作成したトピック 】

【ScrollTopicトピックで作成したトピック】

上のような違いはNoScrollTopicとScrollTopicの段落書式の下の「次の段落と分離しない」（赤丸部分）がチェックされているかどうか関係します。

NoScrollTopicはチェックあり、ScrollTopicはチェックなしになっています。


リンクの自動生成

リンクの自動生成をします。

① 文末に赤点線の文を入力してください。
注意 “トピック３□を”というように“トピック３”と“を”の間に空白を挿入して下さい。助詞がつながっていると“トピック３”が検索されません。多少コツが必要な訳です。

② HELPWORDツールバーの「HELPWORD編集－リンク自動生成」を選び、ホットスポットダイアログを開きます。

③ トピックの一覧から“トピック２”と“トピック３”を選択します。

④ 作成ボタンを押します。

リンクの自動生成が行われます。


トピックダイアログでのキー登録

トピックダイアログを使ってキーワードを登録します。

① “好きなタイトル”トピックのタイトルを選択し、ダブルクリックしてトピックダイアログを開きます。

② キー・タブを選択します。

③ “キー１”、改行、“キー２”と入力します。
Ctrlキーと同時にEnterキーを押すと改行になります。

この設定で一旦Winヘルプを作成してみて下さい。WINヘルプのキーワード・タブを開くと次のようになっていることが確認できます｡


トピックの本文にキーを設定する

キーを指定する方法にはトピックの本文で直接指定する方法があります。

キーワードを登録したいトピックの本文の言葉を選んでHELPWORDツールバーのキーボタンを押します。

① トピックの本文の“トピック１の記事”を選択します。

② HELPWORDツールバーのキーボタンを押します。

注意 トピックのタイトル行をキーにしないようにして下さい。

この設定で一旦Winヘルプを作成して下さい。WINヘルプのキーワード・タブを開くと次のようになっていることが確認できます｡

レッスン２はこれで終わりです。トピック自動生成ができるようになったので簡単なWINヘルプなら楽々作成できるようになったと思います。レッスン３では目次の編集方法について説明します。


レッスン３ - TEMPLATE2.DOC

以下のような階層化した目次の雛形－TEMPLATE2.DOCを使って説明します。

【目標】

1. 目次編集ができるようになること。

2. 参照ボタンを追加できるようになること。


目次編集はアウトライン表示で

HELPWORDでは普通のWordによる文書作成の作業で簡単に目次編集することができます。

先ずは見てみましょう。

① TEMPLATE2.DOCを開きます。

② メインメニューの「表示－アウトライン」を選びアウトライン表示にします。

上のWINヘルプの目次と同じように階層化されて表示されます。

目次編集はアウトライン編集そのものです。


目次編集方法

トピック１とトピック２の階層を１段深くします。

① “見出しその１”の行末で改行し、“見出しその１－１”と入力して【⇒】ボタン（赤丸のボタン）を押します。

次のようになります。

WINヘルプを作成して下さい。WINヘルプの目次を見てみます。

HELPWORDの目次編集はWordのアウトライン編集そのものということが分かったと思います。

但し注意があります。Wordでは下のように一挙に階層２段以上深くしても問題ありません。しかしHELPWORDの目次編集では階層は必ず１段ずつ深くするようにして下さい。これはHELPWORDでWINヘルプを作成する時のエラーの原因になります。


アウトライン・レベルについて

アウトラインについてもう少し見てみます。

「表示－印刷レイアウト」を選び、印刷レイアウト表示にします（WordXP、Word2000）。
「表示－ページレイアウト」を選び、ページレイアウト表示にします（Word98、Word97）。

“見出しその１”の行をクリックして、「書式－段落」を選び、段落ダイアログを開きます。

下の赤丸部分に注目して下さい。ここがアウトラインの正体です。レベルはレベル１からレベル９までと階層のない本文があります。この事さえ知っていれば見出し１、見出し２・・・と言ったWordの組込みの段落スタイルに頼ることなく、どんな行でもヘルプの目次に表示できるようになります。


参照ボタンの追加方法

下の赤丸のボタンを参照ボタンと呼びます。

TEMPLATE2.DOCのヘルプには既に参照ボタンが付いています。

しかし基本設定を変えると参照ボタンが付かなくなります。

① 基本設定で一連の設定を“TEST1.HPJ”、“TEST1.HLP”、“TEST1.CNT”と変更し、文書ファイルも“TEST1.DOC”と変更します。

② WINヘルプを作成して下さい。
WINヘルプを見てみると参照ボタンがありません。

これはヘルプワークショップのプロジェクトファイルの設定に問題があるからです。

HELPWORDツールバーの「HELPWORDプロジェクト－WINヘルプ作成」を選び、ヘルプの作成ダイアログを開きます。

③ ヘルプワークショップ実行ボタンを押してヘルプワークショップを実行します。

④ ヘルプ・ワークショップでWindowsボタンを押します。

⑤ Window Propertiesダイアログを開きます。

⑥ Buttonsタブを開き、Browseボタンをチェックします。

⑦ OKボタン押してダイアログを閉じます。

⑧ ツールバーのSave and Compileボタンを押してヘルプファイルを作成します。

作成されたヘルプは次のようになります。参照ボタンはありますが、<< >>ボタンはグレーのままで押すことができません。これはHELPWORDの不細工なところの一つです。実は文書をヘルプ用に変換する時に上のBrowseがチェックされてるかどうかで参照ボタン用変換をするかどうかの判断をしているのです。Browseのチェックは文書の変換の後にしかできないのに・・・。

⑨ もう一度ヘルプの作成ダイアログでヘルプを作成しなおします。
今度は参照ボタンが使えるようになります。

レッスン３はこれで終わりです。WINヘルプを作成についての説明はこれで終わります。レッスン４ではHTMLヘルプの作成方法について説明します。


レッスン４ - レッスン３に引続いて同じ雛形を使って

【目標】

1. HTMLフィルタを使用を含む、HTMLヘルプ作成の基本操作ができるようになる。

2. ホームページに公開することができるようになる。

3. WINヘルプを作成する時、HTMLヘルプを作成する時の違いを理解する。


基本操作

HTMLヘルプの作成します。

① HELPWORDツールバーの HtmlHelpボタンをクリックして HTMLヘルプ作成ダイアログを開きます｡
只HTMLヘルプを作成するだけなら、入力を変更する必要はありません。

② 作成ボタンを押します。
しばらくすると、HTMLヘルプワークショップが起動します。

③ コンパイルボタンを押します。

（Word2000、Word2002の場合はコンパイルする前にする作業が必要です）

TEST1.CHMというファイルがHTMLヘルプです。ダブルクリックして開きます。

なおHTMLヘルプファイル名等を変更したい場合は、適宜変更ができます。

注意 プロジェクト名の拡張子は”hhp”、目次ファイル名は”hhc”、索引ファイル名は”hhk”でなくてはなりません｡


Word2000、WordXPでの余分な作業

HELPWORDがDOC文書をHTMLに変換する機能をWord2000のフォーマット変換を使って行っています。この変換機能に問題があり、HTMLヘルプワークショップで扱えない特殊なタグを含むHTMLを生成するため、Microsoftが用意したHTML Filterというツールを使ってこれらのタグを削除しなくてはないません。

“HTML Filter 2.1 for Office 2000”はMicrosoftのダウンロードサイトからダウンロードできます。

http://office.microsoft.com/japan/downloads/2000/Msohtmf2.aspx

HTML Filterがインストールされると、スタートメニューにMicrosoft Office ツールというメニューからHTML Filterを起動できるようになります。

① HTML Filterを起動します。

② オプションボタンを押してオプションダイアログで以下のような設定にして下さい。

③ 追加ボタンを押して、ダイアログを開き変換されたHTMLファイルを選びます｡
HTMLファイルはHELPWORD文書が保存されているフォルダにあるhtmlフォルダの中にあります。

④ 開くボタンを押します｡

⑤ 適用ボタンを押すます。
余分なタブを削除されたHTMLヘルプ用のHTMLファイルが作成されます。

WordXP専用のHTML Filterはありませんが、試しにWord2000のHTML Filterを使って余分なタグを削除すると、HTMLヘルプ用にうまく変換してくれます。

（WordXPでの正しい方法があるかもしれませんが・・・）


背景色、背景画像の使い方

① HTMLの背景色、背景画像を変更することができます。

② HTMLヘルプ作成ダイアログのHTMLタブを開きます｡

背景色を指定する場合は、背景色をチェックし、背景色を入力します。

背景画像を指定する場合は、背景画像をチェックし、背景画像を入力します。


ホームページ公開用のフレームページ作成

HTMLヘルプの作成ではトピックをHTML化して、HTMLヘルプ・ワークショップで一つのファイルにまとめます｡ホームページで公開する場合は、フレームページを出力しなくてはなりません。

① HTMLヘルプ作成ダイアログを開きます｡

② HTML先頭ページをチェックします。

③ HTML先頭頁左側の幅（目次の幅）を入力します｡

④ 先頭頁ファイル名（フレームページ名）（を入力します｡


ホームページ公開するときの注意

ActiveX対応ブラウザのみ表示できます。一般的にはIE系（恐らくIE3.0以上）と考えた方が良いようです。その他のブラウザ、Netscape系、Opera系でも正常に動作しません。

なおHELPWORDが出力するHTMLファイルはHTMLヘルプランタイムをインストールする仕組みを組み込んでいない為、IE4.0以上でないと表示できません。


WINヘルプとの違い

HTMLヘルプはWINヘルプをより表現力が豊かです。HTMLヘルプの場合、Microsoft Wordの図形描画機能、表、箇条書き等も使用できます。ごく一般的な範囲での編集の場合、まずHTMLヘルプ化できると思います｡

ただし図形等の場合は注意が必要。思わぬ位置にオーバーラップ表示されたりします（後述）。

この表現力の大きさが逆に災い（？）することがあります。以下はTEST1.DOCから作成したHTMLヘルプの一部です｡

トピックタイトルに注目してください｡HTMLヘルプではHELPWORD文書そのままの背景色が表示されています（WINヘルプでは背景色が反映されない）。

HTMLヘルプを作成する場合は、HELPWORD専用段落スタイル（NoScrollTopic、ScrollTopic、PopupTopic、SecondaryTopic、BookmarkPoint）を使用しない方が良いです。

HELPWORD専用段落スタイルのトピックはこの欠点を補う為に組み込んだスタイルです。背景色、枠線以外はScrollTopicと同じです。

単なる目印以上の意味がない背景色や枠線はWINヘルプの中にまで表示されることはありません。

しかしHTMLヘルプでは表示されています。HTMLヘルプを作成する場合は、上記の段落スタイルを使う場合は、背景色や枠線等の属性をクリアしなくてはならなくなるので別の適当な段落スタイルで代用した方が、楽そうなことがわかります。

WINヘルプとHTMLヘルプでは普段何気なく使っている改行（段落区切り）と擬似改行（行区切、SHIFT+Enterでの改行）の効果の違いを考慮しましょう｡

WINヘルプでは改行と擬似改行の違いはWordの印刷レイアウトで表示されるのとあまり変りません｡しかしHTMLヘルプでは改行は<P>というタグに変換され、擬似改行は<BR>というタグに変換されます。この結果HTMLヘルプでは改行は擬似改行より改行幅が大きくなります｡常に改行（行区切）ばかり使用していると、間延びしたヘルプになりかねません。


【箇条書き】

注意事項など

【文書のバックアップ】

HELPWORD文書はまめにバックアップを行うことをお勧めします。

【グループ文書】

HELPWORDはグループ文書（ハイパーリンクで外部文書とリンクしてあるような文書）に対応していません。
HELPWORDでは文書を開く時にサブ文書が含まれる場合は、それらサブ文書を削除する（この場合削除とはサブ文書を自身の文書に取り込むことの意味）かどうかの問い合わせを行い、Yesなら削除します。

【トピックスタイルの設定】

トピックと段落スタイルの関連付けを行う時に、段落スタイル名、標準や、標準インデントなどを使用しないで下さい。
この場合トピック候補の数が非常に大きくなりすぎて、操作性悪化、処理待ち時間の増加やメモリーなどのリソースの大量消費などの悪影響が発生します。

【特殊なブックマーク”HID_*”】

「HID_」で始まるブックマークの定義をむやみに変更、削除しないで下さい。また「HID_」で始まる名前のブックマークを作成しないで下さい。

【目次項目の長さ】

目次項目の文字が長い場合、ヘルプの目次において当該目次項目上にマウスポインターを移動させるとWinHlp32が異常終了することがありました。但しこの現象はWindows95で確認された現象です。同一のヘルプファイルをWindowsNT4.0で表示したところ、目次項目が適当な部分からトリミングされて表示されました。

【Word2000、WordXPでのHTMLヘルプ作成】

Word2000のHTMLフィルタはHTMLファイルで出力してもWord図等のオブジェクトが編集できるような情報が保持されているようになってます。このためHTML Help WorkShopでは正しくヘルプファイルを生成することはできません。これに対処する為に Microsoft Office Html Filter 2.1を使用してください。現在一部のエンコードに対応していませんが、取り敢えず使えます。

HELPWORDでHTMLを作成後、Microsoft Office Html Filter 2.1で一括変換して普通のHtmlファイルにしてから、HTML Help WorkShopでヘルプファイルを作成してください。

Microsoft Office Html Filter 2.1のインストール

【オートコレクト】

オートコレクト機能、特にオートフォーマット機能の用法には注意して下さい｡変な文字化けの原因になります。全てのチェックを外しても良い程です｡

【図形の配置】

HTMLヘルプを作成するつもりで、Wordの作図機能を使う場合、２つの図が近接しているとオーバーラップすることがあります。私は経験的に図形を右クリックして書式設定ダイアログで下のような設定にします。

l WordXPの場合は、図形も折り返しの種類で”行内”を選択します。

l Word97、98、2000などではこの設定ができないことがあります。この場合詳細ボタンを押してレイアウト詳細ダイアログを開き、折り返しの種類を”上下”にします。

また位置関係が重要な二つ以上のオートシェープは必ずグループ化します。

折り返しの種類が”上下”の場合は、調整作業はアンカーの移動を行って位置調整をしますが、それでもHTMLヘルプでは厳密に図形の配置することに難しいので、最後は「大体この文とこの文の間に入れば良い」という大雑把な仕事で納得することになります。

【箇条書き】

HTMLヘルプの場合箇条書きを使う場合、行頭文字と本文の間のタブがHTMLに正しく変換されません。行頭文字と本文の間に隙間を空けるには本文の先頭に全角スペース等を挿入する方法しか思いつきませんでした。

【インデント等の段落書式】

Word98、97ではHTMLヘルプを出力する場合、書式全般を正常に変換できません。